aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-signedjson/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-signedjson/APKBUILD')
-rw-r--r--testing/py3-signedjson/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-signedjson/APKBUILD b/testing/py3-signedjson/APKBUILD
new file mode 100644
index 00000000000..df1902e5693
--- /dev/null
+++ b/testing/py3-signedjson/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-signedjson
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Sign JSON objects with ED25519 signatures"
+url="https://github.com/matrix-org/python-signedjson"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-pynacl py3-canonicaljson py3-unpaddedbase64"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/matrix-org/python-signedjson/archive/v$pkgver.tar.gz"
+builddir="$srcdir/python-signedjson-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="6a51ca901149c653a0da4567e2487fcf737cf36ac51cc337b0af9422261ee3689a99a4fd4c7ffd0ec0c4ef0c97033d78030dd6fab80e11e86371151279d5d6c4 py3-signedjson-1.0.0.tar.gz"