aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-simframe/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-simframe/APKBUILD')
-rw-r--r--testing/py3-simframe/APKBUILD31
1 files changed, 0 insertions, 31 deletions
diff --git a/testing/py3-simframe/APKBUILD b/testing/py3-simframe/APKBUILD
deleted file mode 100644
index fef99d9cb8e..00000000000
--- a/testing/py3-simframe/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
-# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
-pkgname=py3-simframe
-_pkgorig=simframe
-pkgver=1.0.2
-pkgrel=0
-pkgdesc="Python framework for setting up and running scientific simulations"
-url="https://github.com/stammler/simframe/"
-arch="noarch !riscv64 !s390x !armhf !armv7 !x86" #py3-matplotlib #py3-dill
-license="BSD"
-depends="python3 py3-dill py3-h5py py3-matplotlib py3-scipy py3-numpy"
-checkdepends="python3-dev py3-pytest"
-makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/stammler/$_pkgorig/archive/$pkgver/$_pkgorig-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgorig-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- python3 -m pytest
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="
-3ca6e63aa212999a0f139ceb0ae470ba37fed148523e322229400a4aeb18aca7eb64759151c076097b976ff0b01f2598251fbf15d90f6b6957f4198a7c9e2fee py3-simframe-1.0.2.tar.gz
-"