aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-snapshottest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-snapshottest/APKBUILD')
-rw-r--r--testing/py3-snapshottest/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-snapshottest/APKBUILD b/testing/py3-snapshottest/APKBUILD
new file mode 100644
index 00000000000..994327719b5
--- /dev/null
+++ b/testing/py3-snapshottest/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-snapshottest
+pkgver=0.6.0
+pkgrel=3
+pkgdesc="Snapshot testing for pytest, unittest, Django, and Nose"
+url="https://github.com/syrusakbary/snapshottest"
+arch="noarch"
+license="MIT"
+depends="
+ py3-fastdiff
+ py3-termcolor
+ python3
+ "
+makedepends="py3-setuptools"
+checkdepends="
+ py3-django
+ py3-nose
+ py3-pytest
+ py3-pytest-cov
+ py3-six
+ "
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/s/snapshottest/snapshottest-$pkgver.tar.gz"
+builddir="$srcdir/snapshottest-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" pytest --ignore tests/test_pytest.py
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+0f39ec0b2255291d35bcc873b73b3802b427efd53b8d12ab373a76193dfe9d108534980f8081be38fadbf2392915e8e0d63547e5bf0479ea06d8d79cde4016ce snapshottest-0.6.0.tar.gz
+"