aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinx-autoapi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinx-autoapi/APKBUILD')
-rw-r--r--testing/py3-sphinx-autoapi/APKBUILD35
1 files changed, 21 insertions, 14 deletions
diff --git a/testing/py3-sphinx-autoapi/APKBUILD b/testing/py3-sphinx-autoapi/APKBUILD
index 17b81458c6f..68de3a84ead 100644
--- a/testing/py3-sphinx-autoapi/APKBUILD
+++ b/testing/py3-sphinx-autoapi/APKBUILD
@@ -2,31 +2,38 @@
# Maintainer: Galen Abell <galen@galenabell.com>
pkgname=py3-sphinx-autoapi
_pyname=sphinx-autoapi
-pkgver=1.8.1
-pkgrel=0
+pkgver=3.0.0
+pkgrel=1
pkgdesc="Automatic API documentation for Sphinx"
url="https://sphinx-autoapi.readthedocs.io"
-arch="noarch !x86" # build breaks on x86
+arch="noarch !x86" # build breaks on x86
license="MIT"
-depends="python3 py3-astroid py3-jinja2 py3-sphinx py3-unidecode py3-yaml"
-makedepends="py3-setuptools"
-checkdepends="py3-mock py3-pytest"
-source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+depends="python3 py3-astroid py3-jinja2 py3-sphinx py3-anyascii py3-yaml"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-mock py3-pytest py3-beautifulsoup4"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/s/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # TODO re-add failing tests after fixes from new release
- # See https://github.com/readthedocs/sphinx-autoapi/issues/215
- # and https://github.com/readthedocs/sphinx-autoapi/issues/227
- PYTHONPATH="build:$PYTHONPATH" pytest -v -k 'not test_order_members and not test_manual_directives'
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # Test requires network access
+ .testenv/bin/python3 -m pytest \
+ --deselect tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="7170a016cf38b5f9aa259f489b3d26e22597ba192d21c553af1e11f4ecbfd9a56855f531d5caba2b5dfc1ca781fd9ee8f1505b0b06e84c827df2cbc9f770745f sphinx-autoapi-1.8.1.tar.gz"
+sha512sums="
+f59fb203e1b867f02d5757fb3f58dcaf52b936eff67f4837ae75d9cbff24989d19bb254830bf0e2f90bae1760204e8900ea2e30573da654ad0b5223b9c39750d sphinx-autoapi-3.0.0.tar.gz
+"