aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinx-theme-epfl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinx-theme-epfl/APKBUILD')
-rw-r--r--testing/py3-sphinx-theme-epfl/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-sphinx-theme-epfl/APKBUILD b/testing/py3-sphinx-theme-epfl/APKBUILD
index f0a1758c3f1..ceaae71d9a0 100644
--- a/testing/py3-sphinx-theme-epfl/APKBUILD
+++ b/testing/py3-sphinx-theme-epfl/APKBUILD
@@ -3,25 +3,29 @@
pkgname=py3-sphinx-theme-epfl
_pkgname=epfl-sphinx-theme
pkgver=1.1.1
-pkgrel=4
+pkgrel=9
pkgdesc="The EPFL Sphinx theme"
url="https://pypi.org/project/epfl-sphinx-theme/"
arch="noarch"
license="GPL-3.0-only"
depends="python3 py3-sphinx"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-sphinx-theme-epfl" # Backwards compatibility
+replaces="py-sphinx-theme-epfl" # Backwards compatibility
provides="py-sphinx-theme-epfl=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="af36469cbd33c5f8d1a4ebef201838a26dc52c04b1432b6cc49b46bfb74c585aad83da11cc9ebb675ad166573af41b00bed3e4ec770dcd60330599a732196ea0 epfl-sphinx-theme-1.1.1.tar.gz"