aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-cartouche/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinxcontrib-cartouche/APKBUILD')
-rw-r--r--testing/py3-sphinxcontrib-cartouche/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py3-sphinxcontrib-cartouche/APKBUILD b/testing/py3-sphinxcontrib-cartouche/APKBUILD
index d8604b799bf..02c336bacec 100644
--- a/testing/py3-sphinxcontrib-cartouche/APKBUILD
+++ b/testing/py3-sphinxcontrib-cartouche/APKBUILD
@@ -3,25 +3,29 @@
pkgname=py3-sphinxcontrib-cartouche
_pkgname=cartouche
pkgver=1.1.2
-pkgrel=2
+pkgrel=7
pkgdesc="Sphinx cartouche extension"
url="https://github.com/rob-smallshire/cartouche"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-sphinx"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-sphinxcontrib-cartouche" # Backwards compatibility
+replaces="py-sphinxcontrib-cartouche" # Backwards compatibility
provides="py-sphinxcontrib-cartouche=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="cbfc11d9ff545b9d891e218804627a9524af513c1c2eff461c41813b99f7db1336bd14ed95dbf6b5cfcce19f91ac817bb42cd660057b9bf6427daccb4b375462 cartouche-1.1.2.tar.gz"