aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-fulltoc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinxcontrib-fulltoc/APKBUILD')
-rw-r--r--testing/py3-sphinxcontrib-fulltoc/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/py3-sphinxcontrib-fulltoc/APKBUILD b/testing/py3-sphinxcontrib-fulltoc/APKBUILD
index 37cfef996a3..4984d3ce1cd 100644
--- a/testing/py3-sphinxcontrib-fulltoc/APKBUILD
+++ b/testing/py3-sphinxcontrib-fulltoc/APKBUILD
@@ -3,25 +3,29 @@
pkgname=py3-sphinxcontrib-fulltoc
_pkgname=sphinxcontrib-fulltoc
pkgver=1.2.0
-pkgrel=2
+pkgrel=8
pkgdesc="Sphinx fulltoc extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-fulltoc"
+url="https://pypi.org/project/sphinxcontrib-fulltoc"
arch="noarch"
license="Apache-2.0"
depends="py3-sphinx"
-makedepends="py3-pbr py3-setuptools"
+makedepends="py3-pbr py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-sphinxcontrib-fulltoc" # Backwards compatibility
+replaces="py-sphinxcontrib-fulltoc" # Backwards compatibility
provides="py-sphinxcontrib-fulltoc=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="9f806ed3717db65c9d67f9b35a676586484bbd81347216ee25309c3d74427b283e7efe5af48be588fd72d814158250e2ffa85c6c1f3f0358534f8f64fe45d904 sphinxcontrib-fulltoc-1.2.0.tar.gz"