aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-hydomain/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinxcontrib-hydomain/APKBUILD')
-rw-r--r--testing/py3-sphinxcontrib-hydomain/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/testing/py3-sphinxcontrib-hydomain/APKBUILD b/testing/py3-sphinxcontrib-hydomain/APKBUILD
index a39f8ce9126..5448189ec81 100644
--- a/testing/py3-sphinxcontrib-hydomain/APKBUILD
+++ b/testing/py3-sphinxcontrib-hydomain/APKBUILD
@@ -1,31 +1,33 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=py3-sphinxcontrib-hydomain
-pkgver=0.1.0
-pkgrel=0
+pkgver=0.1.0_git20230930
+_commit="5919f40522b5a8a3787daa7a9bca3df737436d5b"
+pkgrel=1
pkgdesc="Sphinx hydomain extension"
url="https://github.com/hylang/sphinxcontrib-hydomain"
arch="noarch"
license="BSD-3-Clause"
depends="py3-sphinx"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
options="!check" # no test suite
-source="$pkgname-$pkgver.tar.gz::https://github.com/hylang/sphinxcontrib-hydomain/archive/refs/tags/v$pkgver.tar.gz
- do-not-insert-stdlib.patch"
-builddir="$srcdir/sphinxcontrib-hydomain-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hylang/sphinxcontrib-hydomain/archive/$_commit.tar.gz"
+builddir="$srcdir/sphinxcontrib-hydomain-$_commit"
replaces="py-sphinxcontrib-hydomain" # for backwards compatibility
provides="py-sphinxcontrib-hydomain=$pkgver-r$pkgrel" # for backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-60bc96105b820cd9523aa8babb3fd00a5f192954486de85dbee24c04d6908024602afe488a0e3c4f182d06a4111a5846625e1adc26c1b940bf6079e0ed23c960 py3-sphinxcontrib-hydomain-0.1.0.tar.gz
-8d2986368c9d79f3b0288a480ada2d861e26401068757e3bb3c26a70978798bb8711e2a695fbb15cf93dcf0b5cf57173f1bed37bbaefb2c273b5f80defda834b do-not-insert-stdlib.patch
+5e429b1ac8b2deb67a3ae716976a4f8e4ee85d1bfa6ef7236f26b6992ce4f97a5a53fac650d4026c4cd2f812ad556604824482edf4ac166aab15a8dfb29aa2e8 py3-sphinxcontrib-hydomain-0.1.0_git20230930.tar.gz
"