aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-inheritance/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinxcontrib-inheritance/APKBUILD')
-rw-r--r--testing/py3-sphinxcontrib-inheritance/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/py3-sphinxcontrib-inheritance/APKBUILD b/testing/py3-sphinxcontrib-inheritance/APKBUILD
index 28fc945781d..8891a0fce4b 100644
--- a/testing/py3-sphinxcontrib-inheritance/APKBUILD
+++ b/testing/py3-sphinxcontrib-inheritance/APKBUILD
@@ -3,25 +3,29 @@
pkgname=py3-sphinxcontrib-inheritance
_pkgname=sphinxcontrib-inheritance
pkgver=0.9.0
-pkgrel=3
+pkgrel=9
pkgdesc="Sphinx inheritance functionality"
-url="https://pypi.python.org/pypi/sphinxcontrib-inheritance"
+url="https://pypi.org/project/sphinxcontrib-inheritance"
arch="noarch"
license="BSD-2-Clause"
depends="python3 py3-sphinx py3-path"
-makedepends="python3-dev py3-setuptools"
+makedepends="python3-dev py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-sphinxcontrib-inheritance" # Backwards compatibility
+replaces="py-sphinxcontrib-inheritance" # Backwards compatibility
provides="py-sphinxcontrib-inheritance=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="979a8ed286616c2b2981e5581492e0de5b4cee1d6117ed93d098591872fc5c46b813b72042da9d40169086dda503a97ef320884fb601d18ba20d079a2886d412 sphinxcontrib-inheritance-0.9.0.tar.gz"