aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-manpage/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinxcontrib-manpage/APKBUILD')
-rw-r--r--testing/py3-sphinxcontrib-manpage/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/py3-sphinxcontrib-manpage/APKBUILD b/testing/py3-sphinxcontrib-manpage/APKBUILD
index d96fafd0c57..bf542fc2f45 100644
--- a/testing/py3-sphinxcontrib-manpage/APKBUILD
+++ b/testing/py3-sphinxcontrib-manpage/APKBUILD
@@ -3,25 +3,29 @@
pkgname=py3-sphinxcontrib-manpage
_pkgname=sphinxcontrib-manpage
pkgver=0.6
-pkgrel=2
+pkgrel=8
pkgdesc="Sphinx manpage extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-manpage"
+url="https://pypi.org/project/sphinxcontrib-manpage"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-sphinx py3-nwdiag"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-sphinxcontrib-manpage" # Backwards compatibility
+replaces="py-sphinxcontrib-manpage" # Backwards compatibility
provides="py-sphinxcontrib-manpage=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="312215626275cade4595db044b9b1f90eeb816d4cd5277e1f628f164faa67d7c912d5ea295b68ed436e39276448fe27ae0f0aea6062af2fbf48e957bd9dc2d36 sphinxcontrib-manpage-0.6.tar.gz"