aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-nwdiag/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinxcontrib-nwdiag/APKBUILD')
-rw-r--r--testing/py3-sphinxcontrib-nwdiag/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/testing/py3-sphinxcontrib-nwdiag/APKBUILD b/testing/py3-sphinxcontrib-nwdiag/APKBUILD
index 418cb1ad853..8a716f9af9d 100644
--- a/testing/py3-sphinxcontrib-nwdiag/APKBUILD
+++ b/testing/py3-sphinxcontrib-nwdiag/APKBUILD
@@ -3,26 +3,29 @@
pkgname=py3-sphinxcontrib-nwdiag
_pkgname=sphinxcontrib-nwdiag
pkgver=2.0.0
-pkgrel=1
+pkgrel=7
pkgdesc="Sphinx nwdiag extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-nwdiag"
+url="https://pypi.org/project/sphinxcontrib-nwdiag"
arch="noarch"
license="BSD-2-Clause"
depends="py3-nwdiag py3-sphinx"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-sphinxcontrib-nwdiag" # for backwards compatibility
+replaces="py-sphinxcontrib-nwdiag" # for backwards compatibility
provides="py-sphinxcontrib-nwdiag=$pkgver-r$pkgrel" # for backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-
sha512sums="a77d8259a4c1f238dec20ef0c260e6e0ad4665ab13e0124a5cdd3dc135969b44c218131746cc9f955a3dd088bf3b17e23354f8edc0409a239ca2e02d38ec645a sphinxcontrib-nwdiag-2.0.0.tar.gz"