aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-restbuilder/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinxcontrib-restbuilder/APKBUILD')
-rw-r--r--testing/py3-sphinxcontrib-restbuilder/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/testing/py3-sphinxcontrib-restbuilder/APKBUILD b/testing/py3-sphinxcontrib-restbuilder/APKBUILD
index 542a1ca13ee..a8c1278a64a 100644
--- a/testing/py3-sphinxcontrib-restbuilder/APKBUILD
+++ b/testing/py3-sphinxcontrib-restbuilder/APKBUILD
@@ -2,26 +2,32 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-sphinxcontrib-restbuilder
_pkgname=sphinxcontrib-restbuilder
-pkgver=0.2
-pkgrel=2
+pkgver=0.3
+pkgrel=6
pkgdesc="Sphinx restbuilder extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-restbuilder"
+url="https://pypi.org/project/sphinxcontrib-restbuilder"
arch="noarch"
license="BSD-2-Clause"
depends="python3 py3-sphinx"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-sphinxcontrib-restbuilder" # Backwards compatibility
+replaces="py-sphinxcontrib-restbuilder" # Backwards compatibility
provides="py-sphinxcontrib-restbuilder=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="502c051c7bb2295ce1e017a767d49259d19a0aa94c4d3a84a54081cd2fa104c2e8d39f4405cfcc19a4103ffb5fd8e63ff0dbc555d5d83d7098799d1e3d083810 sphinxcontrib-restbuilder-0.2.tar.gz"
+sha512sums="
+6e718b599b2e8db1c89e79efd9e57025c3a0624db7d895f3fcc8c6ed09839a354661c79160c56c2a716a544f5ab0fb27c0f9b0f302065efa9dd3d4d76cb70edc sphinxcontrib-restbuilder-0.3.tar.gz
+"