aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-tabulate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-tabulate/APKBUILD')
-rw-r--r--testing/py3-tabulate/APKBUILD36
1 files changed, 0 insertions, 36 deletions
diff --git a/testing/py3-tabulate/APKBUILD b/testing/py3-tabulate/APKBUILD
deleted file mode 100644
index fddbaed23bf..00000000000
--- a/testing/py3-tabulate/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Maintainer: Andy Postnikov <apostnikov@gmail.com>
-pkgname=py3-tabulate
-pkgver=0.8.7
-pkgrel=2
-pkgdesc="Pretty-print tabular data"
-url="https://bitbucket.org/astanin/python-tabulate"
-arch="noarch"
-license="MIT"
-depends="python3 py3-wcwidth"
-makedepends="py3-setuptools"
-checkdepends="py3-nose"
-source="https://files.pythonhosted.org/packages/source/t/tabulate/tabulate-$pkgver.tar.gz"
-builddir="$srcdir/tabulate-$pkgver"
-
-replaces=py-tabulate # Backwards compatibility
-provides=py-tabulate=$pkgver-r$pkgrel # Backwards compatibility
-
-prepare() {
- default_prepare
- # fix interpreter invocation
- sed -i 's/"python"/"python3"/g' test/test_cli.py
-}
-
-build() {
- python3 setup.py build
-}
-
-check() {
- PYTHONPATH="$builddir"/build/lib python3 setup.py test
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="963d12970227671fc80d26feacfafd37404034eba82778cee2450b8dbc7c723a7137209b601bc2adc13883543bff0d6b887ed2e7b91934a7f2ca4704ce5fd340 tabulate-0.8.7.tar.gz"