aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-tailer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-tailer/APKBUILD')
-rw-r--r--testing/py3-tailer/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/testing/py3-tailer/APKBUILD b/testing/py3-tailer/APKBUILD
index 9f9a036a677..df30c3b17ec 100644
--- a/testing/py3-tailer/APKBUILD
+++ b/testing/py3-tailer/APKBUILD
@@ -1,23 +1,29 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-tailer
-_pkgname=tailer
pkgver=0.4.1
-pkgrel=2
+pkgrel=7
pkgdesc="Python tail is a simple implementation of GNU tail and head"
url="https://github.com/six8/pytailer"
arch="noarch"
license="MIT"
-depends="python3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+makedepends="py3-gpep517 py3-wheel py3-setuptools"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/t/tailer/tailer-$pkgver.tar.gz"
+builddir="$srcdir/tailer-$pkgver"
+options="!check" # no tests provided
-builddir="$srcdir"/$_pkgname-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="c1f0f4cf9356c58366e3d86087bc922378a5d5d9833385e8b0f9acd16211a7ff486c4ea3be13208b85a9766b3fa163071216de54c7170395c18ba6da61650da3 tailer-0.4.1.tar.gz"
+sha512sums="
+c1f0f4cf9356c58366e3d86087bc922378a5d5d9833385e8b0f9acd16211a7ff486c4ea3be13208b85a9766b3fa163071216de54c7170395c18ba6da61650da3 tailer-0.4.1.tar.gz
+"