aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-tasklib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-tasklib/APKBUILD')
-rw-r--r--testing/py3-tasklib/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-tasklib/APKBUILD b/testing/py3-tasklib/APKBUILD
new file mode 100644
index 00000000000..c5d406fac0d
--- /dev/null
+++ b/testing/py3-tasklib/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Edd Salkield <edd@salkield.uk>
+# Maintainer: Edd Salkield <edd@salkield.uk>
+pkgname=py3-tasklib
+pkgver=2.5.1
+pkgrel=2
+pkgdesc="A Python library for interacting with taskwarrior databases"
+url="https://github.com/GothenburgBitFactory/tasklib"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 task py3-tz py3-tzlocal"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/GothenburgBitFactory/tasklib/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/tasklib-$pkgver"
+options="!check" # no upstream tests
+
+package() {
+ python3 setup.py install \
+ --prefix=/usr \
+ --root="$pkgdir" \
+ --single-version-externally-managed
+}
+sha512sums="
+b52a94e487eb90776a5edec63bfef9a4eaa5a87065be3a5386bd0d8b277b88fb35663ea5789e573a088e54fb9aa835c27d787fced4ed5198badff995dcc2e7e0 py3-tasklib-2.5.1.tar.gz
+"