aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-telegram-bot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-telegram-bot/APKBUILD')
-rw-r--r--testing/py3-telegram-bot/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/py3-telegram-bot/APKBUILD b/testing/py3-telegram-bot/APKBUILD
new file mode 100644
index 00000000000..a591d6d772f
--- /dev/null
+++ b/testing/py3-telegram-bot/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-telegram-bot
+_pkgname=python-telegram-bot
+pkgver=20.8
+pkgrel=1
+pkgdesc="A Python wrapper around the Telegram Bot API"
+url="https://github.com/python-telegram-bot/python-telegram-bot"
+arch="noarch"
+license="LGPL-3.0-or-later"
+depends="py3-future py3-certifi py3-tornado py3-cryptography py3-decorator"
+#checkdepends="pytest py-cffi py-cryptography py-future py-pathlib2"
+options="!check" # few requirements-dev.txt packages missing in alpine
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/python-telegram-bot/python-telegram-bot/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-telegram-bot" # Backwards compatibility
+provides="py-telegram-bot=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+835a62bca5c14f06b3db682e3e5af732ab17c32ff89df1020d6cf30217c7db86f800a05f55e977dbd59cb9d46b26e03bc262ace48cd3f5b2ff1c63eb109b81c7 py3-telegram-bot-20.8.tar.gz
+"