aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-telegram-bot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-telegram-bot/APKBUILD')
-rw-r--r--testing/py3-telegram-bot/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/testing/py3-telegram-bot/APKBUILD b/testing/py3-telegram-bot/APKBUILD
index 9d619f3979c..a591d6d772f 100644
--- a/testing/py3-telegram-bot/APKBUILD
+++ b/testing/py3-telegram-bot/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-telegram-bot
_pkgname=python-telegram-bot
-pkgver=13.12
-pkgrel=0
+pkgver=20.8
+pkgrel=1
pkgdesc="A Python wrapper around the Telegram Bot API"
url="https://github.com/python-telegram-bot/python-telegram-bot"
arch="noarch"
@@ -12,6 +12,7 @@ depends="py3-future py3-certifi py3-tornado py3-cryptography py3-decorator"
#checkdepends="pytest py-cffi py-cryptography py-future py-pathlib2"
options="!check" # few requirements-dev.txt packages missing in alpine
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/python-telegram-bot/python-telegram-bot/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -27,9 +28,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-eeb66f6bd5f74e69b082966a72a3ed974df81fe79bef19e72301a09548943da534b974922067624bcb7898d03b9edd13f0ba5e831f1a763e9a340d735a63ce10 py3-telegram-bot-13.12.tar.gz
+835a62bca5c14f06b3db682e3e5af732ab17c32ff89df1020d6cf30217c7db86f800a05f55e977dbd59cb9d46b26e03bc262ace48cd3f5b2ff1c63eb109b81c7 py3-telegram-bot-20.8.tar.gz
"