aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-telegram/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-telegram/APKBUILD')
-rw-r--r--testing/py3-telegram/APKBUILD27
1 files changed, 11 insertions, 16 deletions
diff --git a/testing/py3-telegram/APKBUILD b/testing/py3-telegram/APKBUILD
index 331ab05c3b4..0a0c22e2689 100644
--- a/testing/py3-telegram/APKBUILD
+++ b/testing/py3-telegram/APKBUILD
@@ -2,19 +2,18 @@
# Maintainer: j.r <j.r@jugendhacker.de>
pkgname=py3-telegram
_pyname=python-telegram
-pkgver=0.14.0
-pkgrel=0
+pkgver=0.18.0
+pkgrel=2
pkgdesc="Python client for the Telegram's tdlib"
url="https://github.com/alexander-akhmetov/python-telegram"
-arch="noarch !s390x !mips !mips64"
+arch="noarch !s390x"
license="MIT"
-depends="python3 telegram-tdlib>=1.7.0"
+depends="python3 telegram-tdlib py3-telegram-text"
makedepends="py3-setuptools"
-subpackages="$pkgname-doc"
-source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz
- https://raw.githubusercontent.com/alexander-akhmetov/python-telegram/$pkgver/LICENSE
- 0001-Use-system-tdlib.patch
- 0002-Remove-binarys.patch"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/python-telegram/python-telegram-$pkgver.tar.gz
+ 0002-Remove-binarys.patch
+ "
builddir="$srcdir/$_pyname-$pkgver/"
options="!check"
@@ -23,14 +22,10 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- install -Dm644 $srcdir/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-bea861dc6b0349aea5da60b8c2e307a0486c2069f738240b0408f7cdccfee396b51822c059da95e1716ba8dc65ec0879988cf04337f15d4ca7b64ad0f446bb0d python-telegram-0.14.0.tar.gz
-b038c7b0c6138ff6f215a45d0da25ac8e3b52e3849087e90f68d3ebe246fbcd17c1f78f2ee3c020bfc759334d35709a1ac28b71c74091912dbf165785a3f5895 LICENSE
-7521f123e0d3719eb8db2a6c2b120377f1ee9dbd235ad92cc91ab5b5e4ce0884692721a4fc478c8058038d24b8cae8dd8a0e5eed8d568bc769bdc80b8f2e3327 0001-Use-system-tdlib.patch
-8c24db516797f8ffa8695b31be6364087ed9e6cfb9fc49bc8f68fdcb259b88dcf786afa71d30848bad50c4a201ea8d09f28fb5b86da023404f7ef6c4d17d3447 0002-Remove-binarys.patch
+3137695894f8d88d71619231739601219acb3d8f4c00ab4cc6ecf79fd6aa5a36c6c025e9287d5dce03d53f75a065330d47a7a829bf6e25e29568bb9caf297d67 python-telegram-0.18.0.tar.gz
+7931b19b34806fe84361d3e15fc39330e0b93f4945e7bb892b7b0c78a717a484040b5ad60d9c77063bb452badab2ada314032bfe2064918999e9e7a6863cb5c1 0002-Remove-binarys.patch
"