aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-testresources/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-testresources/APKBUILD')
-rw-r--r--testing/py3-testresources/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-testresources/APKBUILD b/testing/py3-testresources/APKBUILD
index 8fc85a65b85..eff36f96ef4 100644
--- a/testing/py3-testresources/APKBUILD
+++ b/testing/py3-testresources/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-testresources
_pyname=testresources
pkgver=2.0.1
-pkgrel=2
+pkgrel=5
pkgdesc="A pyunit extension for managing expensive test resources"
url="https://launchpad.net/testresources"
arch="noarch"
@@ -11,6 +11,7 @@ license="Apache-2.0 OR BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools py3-pbr"
checkdepends="py3-testtools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
@@ -23,7 +24,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/testresources/tests/
}