aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-tg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-tg/APKBUILD')
-rw-r--r--testing/py3-tg/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/testing/py3-tg/APKBUILD b/testing/py3-tg/APKBUILD
index 280f4a6d056..e2c5ddcc5f1 100644
--- a/testing/py3-tg/APKBUILD
+++ b/testing/py3-tg/APKBUILD
@@ -2,15 +2,18 @@
# Maintainer: j.r <j.r@jugendhacker.de>
pkgname=py3-tg
_pyname=tg
-pkgver=0.17.0
-pkgrel=2
+pkgver=0.19.0
+pkgrel=4
pkgdesc="Terminal telegram client that really works"
url="https://github.com/paul-nameless/tg"
-arch="noarch !s390x !mips !mips64"
+arch="noarch !s390x"
license="Unlicense"
depends="python3 py3-telegram py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/paul-nameless/tg/archive/refs/tags/v$pkgver.tar.gz
- 0001-Change-setup.py-to-accept-new-python-telegram-ver.patch"
+subpackages="$pkgname-pyc"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/paul-nameless/tg/archive/refs/tags/v$pkgver.tar.gz
+ 0001-Allow-newer-python-telegram.patch
+ "
builddir="$srcdir/$_pyname-$pkgver"
options="!check"
@@ -19,10 +22,10 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-8e72317baad9117f542188d62fc599cccb02212311bd75a8acf1221da960ad0b67d58408d458828633a8baa8e3b62e6f3ceb5ec9800b5cb291497c016f444afd py3-tg-0.17.0.tar.gz
-a9549ce7749235e8310cf1b79408ecfab3cabcbbc4c4189f396cd35eb957dd96bd66f7b076a2b2ea37d77fbc78c64bff55b791f0e6cb5ae6a86f70566d2b74c1 0001-Change-setup.py-to-accept-new-python-telegram-ver.patch
+ccaba3614d72d7fc115d8f6e1cb51c52a5e7be3b588a8135c9435226df98c55a4f3184c1e280e26913e982c65cc393f09981ed2612adbdd718bfc70d4ad28ffe py3-tg-0.19.0.tar.gz
+3a9c5e546f388842aa6f270bbf86cc45f98f29779fed02d2c381d7e35f2435f883bfea43bf6448e9c9cbace8be51494a97ecbc8aebe9c23b412aec059bfa757e 0001-Allow-newer-python-telegram.patch
"