aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-typed-ast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-typed-ast/APKBUILD')
-rw-r--r--testing/py3-typed-ast/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/testing/py3-typed-ast/APKBUILD b/testing/py3-typed-ast/APKBUILD
index 53838ec582f..b55d10e81b9 100644
--- a/testing/py3-typed-ast/APKBUILD
+++ b/testing/py3-typed-ast/APKBUILD
@@ -19,7 +19,11 @@ build() {
}
check() {
- PYTHONPATH="$builddir/build/lib.linux-$CARCH-3.7" py.test-3 -v
+ case "$CARCH" in
+ x86) _CARCH=i686 ;;
+ *) _CARCH="$CARCH" ;;
+ esac
+ PYTHONPATH="$builddir/build/lib.linux-$_CARCH-3.7" py.test-3 -v
}
package() {