aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-tzlocal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-tzlocal/APKBUILD')
-rw-r--r--testing/py3-tzlocal/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/testing/py3-tzlocal/APKBUILD b/testing/py3-tzlocal/APKBUILD
index c0b03a88086..cb1770316d4 100644
--- a/testing/py3-tzlocal/APKBUILD
+++ b/testing/py3-tzlocal/APKBUILD
@@ -1,8 +1,7 @@
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=py3-tzlocal
-_pkgname=tzlocal
-pkgver=2.0.0
-pkgrel=1
+pkgver=2.1
+pkgrel=0
pkgdesc="Python tzinfo object for the local timezone"
url="https://github.com/regebro/tzlocal"
arch="noarch"
@@ -11,8 +10,8 @@ replaces="py-tzlocal" # for backwards compatibility
provides="py-tzlocal=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3 py3-tz"
makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+source="https://files.pythonhosted.org/packages/source/t/tzlocal/tzlocal-$pkgver.tar.gz"
+builddir="$srcdir/tzlocal-$pkgver"
options="!check" # the package requires a configured timezone
build() {
@@ -23,4 +22,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="b72487f791df1dda7370ef5de58e524a451bf87a2ad5ce9d365591fb45af1e080499956d9b19410aeacdf3013ce09c84cd3ec243e15d3bbbee4cec32685298d9 tzlocal-2.0.0.tar.gz"
+sha512sums="5419f3316dfcbf0355cc6f0790454fe6cecfa8b1ae17bfa7bf8aff89b0af3e63c94ffe9c22b11f612e53826a33e7179ff71bc2a86f6a358cdff36c7ae34e2453 tzlocal-2.1.tar.gz"