aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ufonormalizer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-ufonormalizer/APKBUILD')
-rw-r--r--testing/py3-ufonormalizer/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/testing/py3-ufonormalizer/APKBUILD b/testing/py3-ufonormalizer/APKBUILD
index eec69e3bb4c..11a73d1a3b7 100644
--- a/testing/py3-ufonormalizer/APKBUILD
+++ b/testing/py3-ufonormalizer/APKBUILD
@@ -2,18 +2,20 @@
# Maintainer: Sascha Brawer <sascha@brawer.ch>
pkgname=py3-ufonormalizer
_pyname=ufonormalizer
-pkgver=0.4.2
-pkgrel=1
+pkgver=0.6.1
+pkgrel=2
pkgdesc="Normalize the XML and other data inside UFO font design sources"
url="https://github.com/unified-font-object/ufoNormalizer"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-setuptools_scm"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/u/$_pyname/$_pyname-$pkgver.zip"
builddir="$srcdir/$_pyname-$pkgver"
build() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
python3 setup.py build
}
@@ -22,10 +24,11 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
# Make files world-readable so others than root can run the installed script.
chmod -R a+r "$pkgdir"/usr/lib/python3*/site-packages
}
-
-sha512sums="023e52fc6bf3bebdd75b81efc61f8ab3e4c6a62dfb3f6e63efb5a9f4998fcd471be37caab6d8f59733d6f68b1486dfd3f675fb2835f693f5705c7e93a3f07429 ufonormalizer-0.4.2.zip"
+sha512sums="
+301bef368a7d42333d885437322991d075e5ebb7169e3397e1d2a486ae18d4efba4db625bad1f9452f512e0a452ec8a9fd0b5c716c8571eb45f9d4d2718f37a7 ufonormalizer-0.6.1.zip
+"