aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-uptime/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-uptime/APKBUILD')
-rw-r--r--testing/py3-uptime/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-uptime/APKBUILD b/testing/py3-uptime/APKBUILD
index 4ecc3b504be..adf1cf61687 100644
--- a/testing/py3-uptime/APKBUILD
+++ b/testing/py3-uptime/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-uptime
_pkgname=uptime
pkgver=3.0.1
-pkgrel=4
+pkgrel=8
pkgdesc="A Python uptime library"
url="https://github.com/Cairnarvon/uptime"
arch="all"
@@ -12,6 +12,7 @@ replaces="py-uptime" # for backwards compatibility
provides="py-uptime=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
makedepends="python3-dev py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -22,7 +23,7 @@ build() {
package() {
cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="55df1c30aa4be3e873ad36d0f784d49bc127d2bd38041c1453b112474dd52033e55d277172d8fdd73b3fabc7bf5071f29329d2a828244ef420d2da7db0f49a54 uptime-3.0.1.tar.gz"