aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-vici/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-vici/APKBUILD')
-rw-r--r--testing/py3-vici/APKBUILD41
1 files changed, 0 insertions, 41 deletions
diff --git a/testing/py3-vici/APKBUILD b/testing/py3-vici/APKBUILD
deleted file mode 100644
index 675654a9025..00000000000
--- a/testing/py3-vici/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Maintainer: Noel Kuntze <noel.kuntze@thermi.consulting>
-pkgname=py3-vici
-pkgver=5.9.3
-pkgrel=0
-pkgdesc="Native Python interface for strongSwan's VICI protocol"
-url="https://strongswan.org"
-arch="noarch"
-license="MIT"
-depends="python3"
-makedepends="automake autoconf py3-setuptools"
-checkdepends="py3-pytest py3-tox"
-source="https://github.com/strongswan/strongswan/releases/download/$pkgver/strongswan-$pkgver.tar.bz2
- use-sitepackages.patch
- "
-builddir="$srcdir/strongswan-$pkgver"
-
-build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --disable-defaults \
- --enable-python-eggs
-
- cd src/libcharon/plugins/vici/python
- make all
- python3 setup.py build
-}
-
-check() {
- make -C src/libcharon/plugins/vici/python check
-}
-
-package() {
- cd src/libcharon/plugins/vici/python/
- python3 setup.py install --root="$pkgdir" --optimize=1
-}
-
-sha512sums="
-09bd78225415422c8f55c9f0dea2ca70111f42f0deacfaaac30c422109ff64180f6a6a47c6bc54238e8403f0b2f8520122c1eabbeda3f915427fadb838a5df51 strongswan-5.9.3.tar.bz2
-4c53fb194339598c2d4226c152b2624550eac052498f52294202468c3dbf5108590f31326e2ca87ce833839ec2daf1ad991d83088e5388c0bcc5503507f7dae5 use-sitepackages.patch
-"