aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-w3lib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-w3lib/APKBUILD')
-rw-r--r--testing/py3-w3lib/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/py3-w3lib/APKBUILD b/testing/py3-w3lib/APKBUILD
new file mode 100644
index 00000000000..7195698e1fa
--- /dev/null
+++ b/testing/py3-w3lib/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-w3lib
+_pkgname=w3lib
+pkgver=1.15.0
+pkgrel=0
+pkgdesc="A library of web-related functions"
+url="https://github.com/scrapy/w3lib"
+arch="noarch"
+license="BSD"
+depends="python3"
+depends_dev=""
+makedepends="py3-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-w3lib" # Backwards compatibility
+provides="py-w3lib=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="debf3aed14f423eb36d730802cf23a393ec9364bd91d158b9a78a8e6deeb23886dea62a8cd47ab120b080c3b82c19aa6fc2865fdeb33add45a45389dbbfae5fa w3lib-1.15.0.tar.gz"