aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-wbdata/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-wbdata/APKBUILD')
-rw-r--r--testing/py3-wbdata/APKBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/testing/py3-wbdata/APKBUILD b/testing/py3-wbdata/APKBUILD
index d0bdf1969fe..c63d5c5bb34 100644
--- a/testing/py3-wbdata/APKBUILD
+++ b/testing/py3-wbdata/APKBUILD
@@ -2,15 +2,16 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-wbdata
_pkgname=wbdata
-pkgver=0.2.7
-pkgrel=4
+pkgver=1.0.0
+pkgrel=1
pkgdesc="A library to access World Bank data"
options="!check" # Tests are broken
url="https://github.com/oliversherouse/wbdata"
arch="noarch"
license="GPL-2.0-or-later"
depends="python3 py3-decorator"
-makedepends="py3-setuptools"
+makedepends="py3-poetry-core py3-gpep517"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -18,15 +19,22 @@ replaces="py-wbdata" # Backwards compatibility
provides="py-wbdata=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+ .testenv/bin/python3 -m unittest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="5b7d8a556f12414e12f2c6bb8e6cb0ca6961675c1e606f8f2153b6d73911e60e22fca0fe70e82143ea2df5c1b4b156f270b15210eec2a8086936500b15be91fe wbdata-0.2.7.tar.gz"
+sha512sums="
+649d994d4d42e4cadc532212f799a4788317e58bd2d6cfb971f7331622d9df0da04229221eff5cb1ca401b6d9289a8215e242be2f7dfd2607e7eb01cd6c3dbcf wbdata-1.0.0.tar.gz
+"