aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-xmldiff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-xmldiff/APKBUILD')
-rw-r--r--testing/py3-xmldiff/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py3-xmldiff/APKBUILD b/testing/py3-xmldiff/APKBUILD
index fbd153a405e..899f0dbb777 100644
--- a/testing/py3-xmldiff/APKBUILD
+++ b/testing/py3-xmldiff/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Sascha Brawer <sascha@brawer.ch>
pkgname=py3-xmldiff
_pyname=xmldiff
-pkgver=2.4
-pkgrel=1
+pkgver=2.6.3
+pkgrel=0
pkgdesc="Creates diffs of XML files"
url="https://github.com/Shoobx/xmldiff"
arch="noarch"
license="MIT"
-depends="python3 py3-lxml py3-six"
+depends="python3 py3-lxml"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/x/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
@@ -22,7 +23,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="cc96c0d46d251ce1cf664c86f8fc0cc8fef67de6d0472415ae755e32cb86f21495dd144b5ecebba11820297a3f3cae8067c8d3b25b3107a8134b6ea641f2fc07 xmldiff-2.4.tar.gz"
+sha512sums="
+ba25b8cc9866c66bc829a82d1f20108c17a09e2f46735763317f7fd6f60c3920ba6d3114454ead1461de4a59c177065291bb71bebb7ee9c4a03f3584452a9e33 xmldiff-2.6.3.tar.gz
+"