aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-zope-configuration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-zope-configuration/APKBUILD')
-rw-r--r--testing/py3-zope-configuration/APKBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/testing/py3-zope-configuration/APKBUILD b/testing/py3-zope-configuration/APKBUILD
index 9368d8422e0..b6bc723373d 100644
--- a/testing/py3-zope-configuration/APKBUILD
+++ b/testing/py3-zope-configuration/APKBUILD
@@ -2,32 +2,40 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-zope-configuration
_pkgname=zope.configuration
-pkgver=4.4.0
+pkgver=5.0.1
pkgrel=2
pkgdesc="Zope Configuration Markup Language"
-url="http://pypi.python.org/pypi/zope.configuration"
+url="https://pypi.org/project/zope.configuration"
arch="noarch"
license="ZPL-2.1"
-depends="python3 py3-zope-interface py3-setuptools py3-zope-schema py3-zope-i18nmessageid"
+depends="py3-zope-interface py3-setuptools py3-zope-schema py3-zope-i18nmessageid"
+makedepends="py3-gpep517 py3-wheel"
checkdepends="py3-zope-testrunner py3-zope-testing py3-manuel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py-zope-configuration" # Backwards compatibility
+replaces="py-zope-configuration" # Backwards compatibility
provides="py-zope-configuration=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+ .testenv/bin/python3 -m zope.testrunner
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
+ rm -r "$pkgdir"/usr/lib/python*/site-packages/zope/configuration/tests
}
sha512sums="
-6383c8e19ddbde098a545b6f22b21eadc860980e8248d05c2e29832971c2060fcde6f5092425d12198e97851f0b7b5edb0b83cc6725cda433867762778c896f9 zope.configuration-4.4.0.tar.gz
+58fec7b330a4ee5f9bb71238fbcb8f07fdd7b6767cb2d8e054699ffcb915973b9dfead33e5515f40049f6aede233d31624d09d7f84d75b96318e63f8ab454147 zope.configuration-5.0.1.tar.gz
"