aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qbittorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/qbittorrent/APKBUILD')
-rw-r--r--testing/qbittorrent/APKBUILD83
1 files changed, 0 insertions, 83 deletions
diff --git a/testing/qbittorrent/APKBUILD b/testing/qbittorrent/APKBUILD
deleted file mode 100644
index e5976036e84..00000000000
--- a/testing/qbittorrent/APKBUILD
+++ /dev/null
@@ -1,83 +0,0 @@
-# Contributor: Jan Tatje <jan@jnt.io>
-# Contributor: Simon Zeni <simon@bl4ckb0ne.ca>
-# Maintainer: Jan Tatje <jan@jnt.io>
-pkgname=qbittorrent
-pkgver=4.3.9
-pkgrel=1
-pkgdesc="qBittorrent client"
-url="https://www.qbittorrent.org/"
-arch="all !armhf" # libtorrent-rasterbar
-license="GPL-2.0-or-later"
-options="!check" # qBittorrent has no tests
-depends="qt5-qtbase qt5-qtsvg"
-makedepends="cmake boost-dev qt5-qtbase-dev qt5-qttools-dev qt5-qtsvg-dev
- libtorrent-rasterbar-dev"
-subpackages="$pkgname-doc $pkgname-nox $pkgname-nox-openrc:nox_openrc
- $pkgname-nox-doc:nox_doc"
-source="https://downloads.sourceforge.net/project/qbittorrent/qbittorrent/qbittorrent-$pkgver/qbittorrent-$pkgver.tar.gz
- qbittorrent-nox.initd
- qbittorrent-nox.confd
- "
-
-# secfixes:
-# 4.1.6-r3:
-# - CVE-2019-13640
-
-build() {
- # GUI
- cmake -B $pkgname \
- -DWEBUI=OFF \
- -DSTACKTRACE=OFF \
- -DCMAKE_BUILD_TYPE="release" \
- -DCMAKE_INSTALL_PREFIX="/usr"
- cmake --build $pkgname
-
- cmake -B $pkgname-nox \
- -DGUI=OFF \
- -DDBUS=OFF \
- -DSTACKTRACE=OFF \
- -DCMAKE_BUILD_TYPE="release" \
- -DCMAKE_INSTALL_PREFIX="/usr"
- cmake --build $pkgname-nox
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install $pkgname
-}
-
-nox() {
- install="$pkgname-nox.pre-install"
- pkgdesc="qBittorrent client webui"
- depends=""
-
- mkdir -p $subpkgdir
- cd $builddir/$pkgname-nox
- install -d "$subpkgdir"/usr/bin
- mv qbittorrent-nox $subpkgdir/usr/bin/
-}
-
-nox_doc() {
- mkdir -p $subpkgdir
- cd $builddir
- install -d "$subpkgdir"/usr/share/man/man1
- mv doc/qbittorrent-nox.1 $subpkgdir/usr/share/man/man1/
-
- default_doc
-}
-
-nox_openrc() {
- mkdir -p $subpkgdir
- depends="openrc"
- pkgdesc="qBittorrent client webui (OpenRC init scripts)"
- install_if="openrc ${subpkgname%-openrc}=$pkgver-r$pkgrel"
-
- install -m755 -D "$srcdir"/$pkgname-nox.initd \
- "$subpkgdir"/etc/init.d/$pkgname-nox
- install -m644 -D "$srcdir"/$pkgname-nox.confd \
- "$subpkgdir"/etc/conf.d/$pkgname-nox
-}
-sha512sums="
-78de7d3132fd97411fc1ff75053e0d20e68ec604378fd224a047c6ae3d22e44ac103c389bce5e15e70f0e792e80f901f77f7a460437145bdcf9477398b3832d6 qbittorrent-4.3.9.tar.gz
-f856d56dc97af4349a71861624028b334a741ecf546c7782a4530ee9786c8c801b5af5297a86eaa0b0caa29f308530ab1f654300162a4a77330946a47896871f qbittorrent-nox.initd
-c6bf667c5f83dd5fb147245a8088c2672f5a239ac573aa612ae90c060dd09182f2ebb6d972b85f35fd3792f1a8eaa7f6e4b56d0381441c4d9d996ba6022dbcc6 qbittorrent-nox.confd
-"