aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qml-box2d/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/qml-box2d/APKBUILD')
-rw-r--r--testing/qml-box2d/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/qml-box2d/APKBUILD b/testing/qml-box2d/APKBUILD
new file mode 100644
index 00000000000..f1936e6e1d9
--- /dev/null
+++ b/testing/qml-box2d/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Thomas Kienlen <kommander@laposte.net>
+# Maintainer: Thomas Kienlen <kommander@laposte.net>
+pkgname=qml-box2d
+pkgver=0_git20180406
+_sha=b7212d5640701f93f0cd88fbd3a32c619030ae62
+pkgrel=0
+pkgdesc="Box2D QML plugin"
+url="https://github.com/qml-box2d/qml-box2d"
+arch="all"
+license="Zlib"
+makedepends="git qt5-qtbase-dev qt5-qtquickcontrols2-dev"
+depends="qt5-qtquickcontrols2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/qml-box2d/qml-box2d/archive/$_sha.tar.gz"
+builddir="$srcdir/$pkgname-$_sha"
+options="!check" # No test suite
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+}
+
+sha512sums="1ba5d3b29134d47defb268918f027e868f4ffdd7f73bd9601a93fb47496574f42baeb80c7f2d59fda858947a039ec10affbafbbc361a3dc103e737d4c32c28ad qml-box2d-0_git20180406.tar.gz"