aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qtchooser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/qtchooser/APKBUILD')
-rw-r--r--testing/qtchooser/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/qtchooser/APKBUILD b/testing/qtchooser/APKBUILD
new file mode 100644
index 00000000000..3e7f98aa1e7
--- /dev/null
+++ b/testing/qtchooser/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=qtchooser
+pkgver=66
+pkgrel=0
+pkgdesc="Wrap the other Qt tools by searching for different instances of Qt on the system"
+arch="all"
+url="https://code.qt.io/cgit/qtsdk/qtchooser.git/"
+license="GPL-3.0-only OR LGPL-2.1-only"
+source="https://download.qt.io/official_releases/qtchooser/$pkgname-$pkgver.tar.xz
+ qt5.conf
+ "
+subpackages="$pkgname-doc"
+
+build() {
+ bindir=/usr/lib/qtchooser/ make
+}
+
+package() {
+ install_if="qtbase"
+ INSTALL_ROOT="$pkgdir" make install
+
+ install -d "$pkgdir"/etc/xdg/qtchooser
+ install -m644 "$srcdir"/qt5.conf \
+ "$pkgdir"/etc/xdg/qtchooser/
+
+ # Set the default Qt
+ ln -s /etc/xdg/qtchooser/qt5.conf \
+ "$pkgdir"/etc/xdg/qtchooser/default.conf
+}
+sha512sums="0c7d3588ddd7b21e6e9d799204924e06e0b0950c898dfd23088f1e7657b7f821a35579aa062658499809f9d9757e82c3c592591aa2e5ec453463929bf2b33bac qtchooser-66.tar.xz
+aa1c18df9d5279ff00d06a0b3f19223e36e64f6275cf3ebc5a4be1e41bb139787325b88f89e0133e9960a7b2582716962dd5d195202ff68715883ce41babda73 qt5.conf"