aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rdma-core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rdma-core/APKBUILD')
-rw-r--r--testing/rdma-core/APKBUILD39
1 files changed, 0 insertions, 39 deletions
diff --git a/testing/rdma-core/APKBUILD b/testing/rdma-core/APKBUILD
deleted file mode 100644
index 552046e34f8..00000000000
--- a/testing/rdma-core/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Contributor: psykose <alice@ayaya.dev>
-# Maintainer: psykose <alice@ayaya.dev>
-pkgname=rdma-core
-pkgver=39.0
-pkgrel=0
-pkgdesc="RDMA core userspace libraries and daemons"
-url="https://github.com/linux-rdma/rdma-core"
-license="GPL-2.0-only OR BSD-2-Clause"
-arch="all !riscv64" # textrels
-options="!check" # tests are for installation
-makedepends="
- cmake
- eudev-dev
- libdrm-dev
- libnl3-dev
- ninja
- py3-docutils
- "
-subpackages="$pkgname-libs $pkgname-dev $pkgname-doc $pkgname-openrc"
-source="https://github.com/linux-rdma/rdma-core/releases/download/v$pkgver/rdma-core-$pkgver.tar.gz"
-
-build() {
- cmake -B build -G Ninja \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- -DCMAKE_INSTALL_SYSCONFDIR=/etc \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=MinSizeRel
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
- rm -rf "$pkgdir"/usr/lib/systemd
-}
-
-sha512sums="
-50b68d791f3b64c1acee3e71c72481890ddd8fe93941fb58508da24b9f6941bd83ede5de98f9a39a4856ee55b715407116a5de6951f24cf09a71b905a5adcb64 rdma-core-39.0.tar.gz
-"