aboutsummaryrefslogtreecommitdiffstats
path: root/testing/reg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/reg/APKBUILD')
-rw-r--r--testing/reg/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/testing/reg/APKBUILD b/testing/reg/APKBUILD
index 536a48e3b6d..deb49f726c7 100644
--- a/testing/reg/APKBUILD
+++ b/testing/reg/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Thomas Kienlen <kommander@laposte.net>
pkgname=reg
pkgver=0.16.1
-pkgrel=5
+pkgrel=20
pkgdesc="Docker registry v2 command line client and repo listing generator with security checks"
url="https://github.com/genuinetools/reg"
license="MIT"
@@ -11,11 +11,14 @@ makedepends="go"
source="https://github.com/genuinetools/reg/archive/v$pkgver/reg-$pkgver.tar.gz"
options="chmod-clean"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go build \
-trimpath \
-ldflags "
- -s -w
-X github.com/genuinetools/reg/version.GITCOMMIT=v$pkgver
-X github.com/genuinetools/reg/version.VERSION=$pkgver-r$pkgrel
" \