aboutsummaryrefslogtreecommitdiffstats
path: root/testing/reg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/reg/APKBUILD')
-rw-r--r--testing/reg/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/testing/reg/APKBUILD b/testing/reg/APKBUILD
index 5f4b26fd7f4..deb49f726c7 100644
--- a/testing/reg/APKBUILD
+++ b/testing/reg/APKBUILD
@@ -2,20 +2,23 @@
# Maintainer: Thomas Kienlen <kommander@laposte.net>
pkgname=reg
pkgver=0.16.1
-pkgrel=1
+pkgrel=20
pkgdesc="Docker registry v2 command line client and repo listing generator with security checks"
url="https://github.com/genuinetools/reg"
license="MIT"
-arch="all"
+arch="all !riscv64"
makedepends="go"
source="https://github.com/genuinetools/reg/archive/v$pkgver/reg-$pkgver.tar.gz"
options="chmod-clean"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go build \
-trimpath \
-ldflags "
- -s -w
-X github.com/genuinetools/reg/version.GITCOMMIT=v$pkgver
-X github.com/genuinetools/reg/version.VERSION=$pkgver-r$pkgrel
" \