aboutsummaryrefslogtreecommitdiffstats
path: root/testing/reprotest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/reprotest/APKBUILD')
-rw-r--r--testing/reprotest/APKBUILD33
1 files changed, 23 insertions, 10 deletions
diff --git a/testing/reprotest/APKBUILD b/testing/reprotest/APKBUILD
index 806c33bdf6e..af1ca8eaeea 100644
--- a/testing/reprotest/APKBUILD
+++ b/testing/reprotest/APKBUILD
@@ -1,29 +1,42 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Contributor: fossdd <fossdd@pwned.life>
+# Maintainer: fossdd <fossdd@pwned.life>
pkgname=reprotest
_pyname=reprotest
-pkgver=0.7.18
+pkgver=0.7.27
pkgrel=0
pkgdesc="Build packages and check them for reproducibility"
url="https://salsa.debian.org/reproducible-builds/reprotest"
-arch="noarch !armv7 !x86 !mips !mips64 !armhf" # diffoscope
+arch="noarch !armv7 !x86 !armhf" # diffoscope
license="GPL-3.0-or-later"
-depends="python3 diffoscope py3-rstr py3-distro"
-makedepends="py3-setuptools py3-wheel"
+depends="diffoscope py3-rstr py3-distro py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="dpkg py3-pytest"
_pypiprefix="${_pyname%"${_pyname#?}"}"
-source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://salsa.debian.org/reproducible-builds/reprotest/-/archive/$pkgver/reprotest-$pkgver.tar.gz"
+options="!check" # missing disorderfs
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
+
sha512sums="
-145000858c2b7b57e9929486475df73e0a4e8a5aa095682a3ee26aa5d8945350cd1d99876c91f2f470f5d16ebbe8b6e281108106210ef248d0be29d237a28f3e reprotest-0.7.18.tar.gz
+5dfbaaffeaf40c56355a61509590c134921e6697e05c25b1436239f42a522ea17c34076600d3ff69b5eae4b6b9578d4e2b79bb5e88e65d2f1e4641adbb842e79 reprotest-0.7.27.tar.gz
"