aboutsummaryrefslogtreecommitdiffstats
path: root/testing/river/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/river/APKBUILD')
-rw-r--r--testing/river/APKBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/testing/river/APKBUILD b/testing/river/APKBUILD
index 72d4935822d..67246ef4612 100644
--- a/testing/river/APKBUILD
+++ b/testing/river/APKBUILD
@@ -1,23 +1,31 @@
# Contributor: Anjandev Momi <anjan@momi.ca>
# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=river
-pkgver=0.1.3
-pkgrel=1
+pkgver=0.3.0
+pkgrel=0
pkgdesc="Dynamic Tiling Wayland Compositor"
-url="https://github.com/riverwm/river"
+url="https://codeberg.org/river/river"
arch="x86_64 aarch64" # limited by zig aport
-license="GPL-3.0-or-later"
-makedepends="libevdev-dev libxkbcommon-dev pixman-dev scdoc wayland-dev
- wayland-protocols wlroots-dev zig
+license="GPL-3.0-only"
+makedepends="
+ libevdev-dev
+ libxkbcommon-dev
+ pixman-dev
+ scdoc
+ wayland-dev
+ wayland-protocols
+ wlroots-dev
+ zig
"
-depends="seatd"
+depends="xwayland seatd"
subpackages="
+ $pkgname-dev
$pkgname-doc
$pkgname-bash-completion
$pkgname-fish-completion
$pkgname-zsh-completion
"
-source="https://github.com/riverwm/river/releases/download/v$pkgver/river-$pkgver.tar.gz"
+source="https://codeberg.org/river/river/releases/download/v$pkgver/river-$pkgver.tar.gz"
# We may want other than "baseline" for other targets, when enabled by zig
case "$CARCH" in
@@ -26,7 +34,7 @@ esac
build() {
# This installs it to $builddir/out
- DESTDIR="$builddir/out" zig build -Drelease-safe --prefix /usr install \
+ DESTDIR="$builddir/out" zig build -Doptimize=ReleaseSafe -Dpie -Dxwayland --prefix /usr install \
${cputarget:+-Dcpu="$cputarget"}
}
@@ -44,14 +52,13 @@ package() {
# Install example configuration
install -Dm0644 example/init -t "$pkgdir"/usr/share/doc/river/examples
+}
- # Fix location of fish completion
- mkdir -p "$pkgdir"/usr/share/fish/completions/
- mv "$pkgdir"/usr/share/fish/vendor_completions.d/*.fish \
- "$pkgdir"/usr/share/fish/completions/
- rm -rf "$pkgdir"/usr/share/fish/vendor_completions.d
+dev() {
+ default_dev
+ amove usr/share/river-protocols
}
sha512sums="
-8dd8ad8b17fb1d9d65e413aaaa456fda89f8bedd580db247c3ffa8235a67712394182b3498a9c6eb3707cfc571c398bb5086cf09810e4a9438d26ea19f41f5a9 river-0.1.3.tar.gz
+d74aabd01781d76f37cc220413850f793f02e78bd966ce67e1c73d5849a9ea308a2619388202b15ee4108ac3c5f19faea91092fbaccb6de65121a3427d3d05e4 river-0.3.0.tar.gz
"