aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rizin-cutter/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rizin-cutter/APKBUILD')
-rw-r--r--testing/rizin-cutter/APKBUILD37
1 files changed, 15 insertions, 22 deletions
diff --git a/testing/rizin-cutter/APKBUILD b/testing/rizin-cutter/APKBUILD
index f85c033a4a6..ae0e68cb2d4 100644
--- a/testing/rizin-cutter/APKBUILD
+++ b/testing/rizin-cutter/APKBUILD
@@ -1,43 +1,37 @@
# Contributor: Leon Marz <main@lmarz.org>
# Maintainer: Leon Marz <main@lmarz.org>
pkgname=rizin-cutter
-pkgver=2.0.4
-pkgrel=1
+pkgver=2.3.2
+pkgrel=2
pkgdesc="Reverse Engineering Platform powered by rizin"
url="https://cutter.re"
-arch="all !x86 !armv7 !armhf !s390x !mips64" # limited by rizin
+arch="all !armhf" # syntax-highlighting not available
license="GPL-3.0-only"
depends="rizin"
-makedepends="cmake
+makedepends="
+ cmake
graphviz-dev
python3-dev
- rizin-dev
- syntax-highlighting-dev
- qt5-qttools-dev
qt5-qtsvg-dev
+ qt5-qttools-dev
+ rizin-dev
+ samurai
+ syntax-highlighting5-dev
"
subpackages="$pkgname-dev"
_translations_commit=974298653ba71b958e1b6c83f6011f5fefff6236
-source="$pkgname-$pkgver.tar.gz::https://github.com/rizinorg/cutter/archive/v$pkgver.tar.gz
- translations.tar.gz::https://github.com/rizinorg/cutter-translations/archive/$_translations_commit.tar.gz
- "
-builddir="$srcdir/cutter-$pkgver"
+source="https://github.com/rizinorg/cutter/releases/download/v$pkgver/Cutter-v$pkgver-src.tar.gz"
+builddir="$srcdir/Cutter-v$pkgver"
options="!check" # upstream does not provide a testsuite
-prepare() {
- default_prepare
-
- rmdir "$builddir/src/translations"
- mv "$srcdir/cutter-translations-$_translations_commit" "$builddir/src/translations"
-}
-
build() {
- cmake -B build \
+ CXXFLAGS="$CXXFLAGS -O2 -flto=auto" \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=None \
-DCUTTER_USE_BUNDLED_RIZIN=OFF \
+ -DCUTTER_USE_ADDITIONAL_RIZIN_PATHS=OFF \
-DCUTTER_ENABLE_GRAPHVIZ=ON \
-DCUTTER_ENABLE_PYTHON=ON
@@ -49,6 +43,5 @@ package() {
}
sha512sums="
-06a5ffcd96e8afc2d947f8f45a5b6bdee3ec4b1c7edcf2cc14e0eac5922400be8f594fe579a0515869dd33b90a07b24f0d4294ad85b3f1cb247b16f8b7cf0826 rizin-cutter-2.0.4.tar.gz
-11450631602e7bd81132650b3edd028d56b2f6343a9561fe8bf3281427d8d22b0296651414756236b8544f719c8d4fc11be44a843532c8c32fe21dd7a82066d2 translations.tar.gz
+65ca98f6618b1e60efa25d33bb4f3ef6b36dfd8496cf1f40c6a6b9744df3c2f77673d1d3cc1142c1b3b064abd0698ca07a20c5e4009ba5f6b05fc7f7501a4435 Cutter-v2.3.2-src.tar.gz
"