aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rofi-pass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rofi-pass/APKBUILD')
-rw-r--r--testing/rofi-pass/APKBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/testing/rofi-pass/APKBUILD b/testing/rofi-pass/APKBUILD
index 4c1ad907280..1603160c7a0 100644
--- a/testing/rofi-pass/APKBUILD
+++ b/testing/rofi-pass/APKBUILD
@@ -1,19 +1,29 @@
# Contributor: Simon Zeni <simon@bl4ckb0ne.ca>
# Maintainer: Simon Zeni <simon@bl4ckb0ne.ca>
-pkgname="rofi-pass"
-pkgver="2.0.2"
-pkgrel=0
+pkgname=rofi-pass
+pkgver=2.0.2
+pkgrel=2
pkgdesc="rofi frontend for pass"
url="https://github.com/carnager/rofi-pass"
-arch="" # disabled because rofi is also disabled
+arch="noarch !s390x !riscv64" # limited by rofi
license="GPL-3.0-only"
-depends="xdg-utils rofi pass gawk pwgen xdotool xclip"
+depends="
+ bash
+ cmd:gawk
+ cmd:pwgen
+ cmd:rofi pass
+ cmd:xclip
+ cmd:xdg-open
+ cmd:xdotool
+ "
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/carnager/rofi-pass/archive/$pkgver.tar.gz"
-options="!check" # No tests
+source="https://github.com/carnager/rofi-pass/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+options="!check" # no tests
package() {
- make -C "$builddir" DESTDIR="$pkgdir" PREFIX="/usr" install
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
}
-sha512sums="28f59696911089c31b3f17bde281e3d79c3f757ecc4da61386719c6cff9b31c0944a2ac549d7838f06c249d4535c0dc107ba684115f15db42a24bfdb2f575437 rofi-pass-2.0.2.tar.gz"
+sha512sums="
+28f59696911089c31b3f17bde281e3d79c3f757ecc4da61386719c6cff9b31c0944a2ac549d7838f06c249d4535c0dc107ba684115f15db42a24bfdb2f575437 rofi-pass-2.0.2.tar.gz
+"