aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rqlite/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rqlite/APKBUILD')
-rw-r--r--testing/rqlite/APKBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/testing/rqlite/APKBUILD b/testing/rqlite/APKBUILD
deleted file mode 100644
index 88f731ea690..00000000000
--- a/testing/rqlite/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: psykose <alice@ayaya.dev>
-# Maintainer: psykose <alice@ayaya.dev>
-pkgname=rqlite
-pkgver=7.4.0
-pkgrel=1
-pkgdesc="Lightweight, distributed relational database built on SQLite"
-url="https://github.com/rqlite/rqlite"
-arch="all !riscv64" # ftbfs
-license="MIT"
-makedepends="go"
-checkdepends="python3 py3-requests"
-options="!check" # a bunch of them fail due to runtime requirements
-subpackages="
- $pkgname-doc
- $pkgname-bench
- $pkgname-client
- "
-source="$pkgname-$pkgver.tar.gz::https://github.com/rqlite/rqlite/archive/refs/tags/v$pkgver.tar.gz"
-
-export GOFLAGS="$GOFLAGS -modcacherw -trimpath"
-
-build() {
- go build ./cmd/rqbench
- go build ./cmd/rqlite
- go build ./cmd/rqlited
-}
-
-check() {
- RQLITED_PATH="$builddir"/rqlited python3 system_test/full_system_test.py
-}
-
-package() {
- install -Dm755 rqbench rqlite rqlited \
- -t "$pkgdir"/usr/bin
-
- install -D -m644 "$builddir"/DOC/*.md -t \
- "$pkgdir"/usr/share/doc/$pkgname
-}
-
-bench() {
- pkgdesc="$pkgdesc (benchmark utility)"
-
- amove usr/bin/rqbench
-}
-
-
-client() {
- pkgdesc="$pkgdesc (client)"
-
- amove usr/bin/rqlite
-}
-
-sha512sums="
-9c5b9cfc3d6f79001b562d3f1717879f377e5b190dcfd96b3f983a40ca3a649b1dc9389970abf8136a344a0b6da84a3e8abd20022a351cf6f1c1f51185df315a rqlite-7.4.0.tar.gz
-"