aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ruby-ast-tdl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ruby-ast-tdl/APKBUILD')
-rw-r--r--testing/ruby-ast-tdl/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/ruby-ast-tdl/APKBUILD b/testing/ruby-ast-tdl/APKBUILD
index ebbc7ff3815..7c7cf467051 100644
--- a/testing/ruby-ast-tdl/APKBUILD
+++ b/testing/ruby-ast-tdl/APKBUILD
@@ -3,13 +3,13 @@
pkgname=ruby-ast-tdl
_gemname=${pkgname#ruby-}
pkgver=0.0.4
-pkgrel=0
+pkgrel=1
pkgdesc="Training Description Language for Artificial Sport Trainer"
url="https://github.com/firefly-cpp/ast-tdl"
arch="noarch"
license="MIT"
depends="ruby"
-options="!check" # no tests in current release
+checkdepends="ruby-minitest"
source="$pkgname-$pkgver.tar.gz::https://github.com/firefly-cpp/$_gemname/archive/$pkgver/$_gemname-$pkgver.tar.gz"
builddir="$srcdir/$_gemname-$pkgver"
@@ -17,6 +17,10 @@ build() {
gem build $_gemname.gemspec
}
+check() {
+ ruby test/test_ast_tdl.rb
+}
+
package() {
local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"