aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ruby-pathutil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ruby-pathutil/APKBUILD')
-rw-r--r--testing/ruby-pathutil/APKBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/testing/ruby-pathutil/APKBUILD b/testing/ruby-pathutil/APKBUILD
deleted file mode 100644
index a4c791710ae..00000000000
--- a/testing/ruby-pathutil/APKBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=ruby-pathutil
-_gemname=pathutil
-pkgver=0.16.2
-pkgrel=0
-pkgdesc="A faster pure Ruby implementation of Pathname with extra bits"
-url="https://github.com/envygeeks/pathutil"
-arch="noarch"
-license="MIT"
-depends="ruby ruby-forwardable-extended"
-checkdepends="ruby-json ruby-rspec ruby-safe_yaml"
-source="https://github.com/envygeeks/pathutil/archive/v$pkgver/$_gemname-$pkgver.tar.gz
- fix-ruby-keyword-parameter.patch::https://github.com/envygeeks/pathutil/commit/3451a10c362fc867b20c7e471a551b31c40a0246.patch
- tests-skip-broken.patch
- tests-remove-unnecessary-requires.patch
- gemspec.patch
- "
-builddir="$srcdir/$_gemname-$pkgver"
-
-build() {
- gem build Gem.gemspec
-}
-
-check() {
- rspec .
-}
-
-package() {
- local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
-
- gem install \
- --local \
- --install-dir "$gemdir" \
- --ignore-dependencies \
- --no-document \
- --verbose \
- $_gemname
-
- # Remove unnecessary files and rubbish...
- cd "$gemdir"
- rm -r cache build_info doc extensions
-}
-
-sha512sums="
-d06daf365b94dacd33966f3928a53f0f00d2fca7b9f6348a7efd2b55ab5ba937459e5bd78fde241f30749a1ae55e4ae3ba1ed8945b5333464e7d3ce9666cd054 pathutil-0.16.2.tar.gz
-cc9f7f94b5a830c6f377e5414da317492caf6b5bd89ee8c414753c09c427b2a87852ce8767effacfd0af2ca260c8b05e322e7772b7cc786c4f4531bcf8107cc2 fix-ruby-keyword-parameter.patch
-1e6433b9403035bc13a51e54683d703842a446afa887a5068a719fd301a6a1ca02e45929cc6a5728870990fbcf70ffd49abc9fe28c939a59f830972eca1c3732 tests-skip-broken.patch
-c3f2a2bda0daaae245168b352510d054594e1b739899a629ee6322f7f8eb1a0d561b4d431d1e38420746f6d60e0887e2719a14e3354163a1a8cc5fc141c55a7b tests-remove-unnecessary-requires.patch
-3e6102cab755624de59d925da8031a0c774052cbb85977a93ca6b45436192152e53b61f9d125898ab47e7761b47ae00f0da5210c229c3ec4ae57005bb5391e72 gemspec.patch
-"