aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ruby-posix-spawn/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ruby-posix-spawn/APKBUILD')
-rw-r--r--testing/ruby-posix-spawn/APKBUILD56
1 files changed, 0 insertions, 56 deletions
diff --git a/testing/ruby-posix-spawn/APKBUILD b/testing/ruby-posix-spawn/APKBUILD
deleted file mode 100644
index dc2eef9b5e9..00000000000
--- a/testing/ruby-posix-spawn/APKBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=ruby-posix-spawn
-_gemname=posix-spawn
-pkgver=0.3.13
-pkgrel=0
-pkgdesc="Ruby process spawning library"
-url="https://github.com/rtomayko/posix-spawn"
-arch="all"
-license="MIT"
-checkdepends="ruby-minitest ruby-rake ruby-rake-compiler"
-makedepends="ruby ruby-dev"
-options="!check" # FIXME: tests fail on builders, cannot reproduce locally
-source="$pkgname-$pkgver.tar.gz::https://github.com/rtomayko/$_gemname/archive/v$pkgver.tar.gz
- gemspec.patch
- tests-skip-failing.patch
- rakefile-skip-build.patch"
-builddir="$srcdir/$_gemname-$pkgver"
-
-build() {
- cd "$builddir"
-
- gem build $_gemname.gemspec
-
- gem install --local \
- --install-dir dist \
- --ignore-dependencies \
- --no-document \
- --verbose \
- $_gemname
-
- # Needed for tests.
- cp -l dist/extensions/*/*/$_gemname-*/*.so lib/
-}
-
-check() {
- cd "$builddir"
-
- rake test
-}
-
-package() {
- local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
- cd "$builddir"/dist
-
- mkdir -p "$gemdir"
- cp -r extensions gems specifications "$gemdir"/
-
- # Remove unnecessary and duplicated files.
- rm -f "$gemdir"/extensions/*/*/$_gemname-*/mkmf.log
-}
-
-sha512sums="8d2714db966f3ef042550f38f6b3adee2c6056d8438e39d35f99ed1ac23fdde09ffbca564d6f5a75548758fc425f1859f2fb1f013f48d66182dad9084e5d641c ruby-posix-spawn-0.3.13.tar.gz
-d22ae3c61aa41681de23e32b77404c06e68e3919af9f98d881fb499788ba9dab52d909c6a5b42fcf77a1ec61c9a2709129150cb50a355365809f5775359e5243 gemspec.patch
-d0ab5f3adb0245dc82f499bd87a6a360c13eb86642630d90bfad062adcf24213e2ce00245b296c73a6b0b14294b1f946afd651977a23d85f49fa11b7f5067954 tests-skip-failing.patch
-32b61aeec77209b26f7944c796f7f14c0f4c3625d1952ccaa7bc5bc1e0754926e0731551fc7b5bb4196a767a452ae48c7a58deb39ea079654df2191d41220c2f rakefile-skip-build.patch"