aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ruby-thor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ruby-thor/APKBUILD')
-rw-r--r--testing/ruby-thor/APKBUILD43
1 files changed, 0 insertions, 43 deletions
diff --git a/testing/ruby-thor/APKBUILD b/testing/ruby-thor/APKBUILD
deleted file mode 100644
index c6c6731b50f..00000000000
--- a/testing/ruby-thor/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
-# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
-pkgname=ruby-thor
-pkgver=1.1.0
-pkgrel=0
-pkgdesc="toolkit for building powerfull command-line interfaces"
-url="http://whatisthor.com/"
-arch="noarch"
-license="MIT"
-depends="ruby"
-checkdepends="ruby-rspec"
-options="!check" # requires simplecov / coverall
-source="$pkgname-$pkgver.tar.gz::https://github.com/rails/thor/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir/thor-$pkgver"
-
-build() {
- gem build thor.gemspec
-}
-
-check() {
- rspec
-}
-
-package() {
- local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
-
- gem install \
- --local \
- --install-dir "$gemdir" \
- --bindir "$pkgdir/usr/bin" \
- --ignore-dependencies \
- --no-document \
- --verbose \
- thor
-
- rm -r "$gemdir"/cache \
- "$gemdir"/extensions \
- "$gemdir"/doc
-}
-
-sha512sums="
-d1872a834478c5a2054dde6f55e93f6765fd628536f99f888bd7495436c88658537d48c44ef1e5ad6d1388edfa294ea2a3f3cbde32c19b7d2253b78bc62bf9d0 ruby-thor-1.1.0.tar.gz
-"