aboutsummaryrefslogtreecommitdiffstats
path: root/testing/s-postgray/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/s-postgray/APKBUILD')
-rw-r--r--testing/s-postgray/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/s-postgray/APKBUILD b/testing/s-postgray/APKBUILD
new file mode 100644
index 00000000000..26c605d5c88
--- /dev/null
+++ b/testing/s-postgray/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Steffen Nurpmeso <steffen@sdaoden.eu>
+pkgname=s-postgray
+pkgver=0.8.2
+pkgrel=0
+pkgdesc="postfix RFC 6647 graylisting policy server"
+url="https://www.sdaoden.eu/code.html#s-toolbox"
+arch="all"
+license="ISC"
+makedepends="linux-headers"
+subpackages="$pkgname-doc"
+source="https://ftp.sdaoden.eu/s-postgray-$pkgver.tar.gz"
+
+build() {
+ local sandbox=0
+ case "$CARCH" in
+ x86_64)
+ sandbox=1
+ ;;
+ esac
+ make VAL_OS_SANDBOX=$sandbox
+}
+
+check() {
+ ./s-postgray-test.sh
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="
+ed6957d3c64c153953fe13de93b2112c202a2ae8b3214d044deab87ef90a12139bbd611a05b388822de2ac1f2547ce4eaf7d493d47b07610a3a8121b84559b3f s-postgray-0.8.2.tar.gz
+"