aboutsummaryrefslogtreecommitdiffstats
path: root/testing/scummvm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/scummvm/APKBUILD')
-rw-r--r--testing/scummvm/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/testing/scummvm/APKBUILD b/testing/scummvm/APKBUILD
index 5af21c0e76f..dab3407df96 100644
--- a/testing/scummvm/APKBUILD
+++ b/testing/scummvm/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Thomas Kienlen <kommander@laposte.net>
# Maintainer: Thomas Kienlen <kommander@laposte.net>
pkgname=scummvm
-pkgver=2.2.0
-pkgrel=1
+pkgver=2.8.1
+pkgrel=0
pkgdesc="Engine for several graphical adventure games"
url="https://www.scummvm.org/"
-arch="all"
+arch="all !ppc64le" # build failure on ppc64le
license="GPL-2.0-or-later"
makedepends="
alsa-lib-dev
@@ -15,6 +15,7 @@ makedepends="
freetype-dev
glu-dev
jpeg-dev
+ libmad-dev
libogg-dev
libpng-dev
libtheora-dev
@@ -26,15 +27,12 @@ subpackages="$pkgname-doc"
source="
https://downloads.scummvm.org/frs/scummvm/$pkgver/scummvm-$pkgver.tar.gz
disable-forbidden.patch
- 0001-FLUIDSYNTH-Simplify-FluidSynth-version-check.patch
- 0002-FLUIDSYNTH-Fix-compilation-with-Fluidsynth-2.2.patch
"
build() {
./configure \
--prefix=/usr \
--enable-all-engines \
- --enable-c++11 \
--enable-release
make
}
@@ -44,8 +42,6 @@ package() {
}
sha512sums="
-53128f59d59bdb1e9cad81c8b33da311ec7e6267a142fc44fd8ebe298c3b341b0f98e03346b47fe08f8fa0d98016b80d3b4a233a6dd9f608b756f8c09160fc94 scummvm-2.2.0.tar.gz
-92e22cc65454ad29dc580b03859cf7b78fdea5614eb370dbad05460bc6aac187b4be99213912ee58c7b9a7d1488bc02b7853337465bbc8c2405f5e4aefadf0f2 disable-forbidden.patch
-bc7bf322eed6fa1479b34a17f0db7f301ed66c6a1aaa81be3833fd317b39a001687b0d91bf572661e632c6234d633add0e545626c6e2bfac5b4e6135068c8106 0001-FLUIDSYNTH-Simplify-FluidSynth-version-check.patch
-fcb3621dc811aeab4ff2d4a5969c9e49991b65ac67cd2dbe0b3e436185ceaface2ed2644b6cce2fa2e37618b8d45849514797009e84bdce3e7c09325a8f9c257 0002-FLUIDSYNTH-Fix-compilation-with-Fluidsynth-2.2.patch
+11bdd0a3d2a3aa53462eaa3d96c4bd0d79053d853627c6958aab0687f4032812ba2f95c883f58cec4580637e541fb903a9d926c7e9e6a9e2e6a41028a77e4002 scummvm-2.8.1.tar.gz
+a44de9540f18893b49b02c083694f8eb974e8ddead6d0c6b0453760d7452367cfcc4613215fab2223da8859ce389a53dd2f110cf3389798761c95efafd886542 disable-forbidden.patch
"