aboutsummaryrefslogtreecommitdiffstats
path: root/testing/shotwell
diff options
context:
space:
mode:
Diffstat (limited to 'testing/shotwell')
-rw-r--r--testing/shotwell/APKBUILD3
-rw-r--r--testing/shotwell/shotwell.post-install7
-rw-r--r--testing/shotwell/shotwell.post-upgrade7
-rw-r--r--testing/shotwell/shotwell.pre-deinstall7
4 files changed, 23 insertions, 1 deletions
diff --git a/testing/shotwell/APKBUILD b/testing/shotwell/APKBUILD
index 17d556a41ad..9825c5153be 100644
--- a/testing/shotwell/APKBUILD
+++ b/testing/shotwell/APKBUILD
@@ -1,11 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shotwell
pkgver=0.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="A digital photo organizer designed for the GNOME desktop environment"
url="http://yorba.org/shotwell/"
arch="all"
license="LGPL2.1"
+install="shotwell.post-upgrade shotwell.post-install shotwell.pre-deinstall"
depends=""
makedepends="intltool vala libgee-dev libunique-dev webkit-dev libexif-dev
librsvg-dev sqlite-dev udev-dev dbus-glib-dev libgphoto2-dev
diff --git a/testing/shotwell/shotwell.post-install b/testing/shotwell/shotwell.post-install
new file mode 100644
index 00000000000..e6135da0452
--- /dev/null
+++ b/testing/shotwell/shotwell.post-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in shotwell.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/testing/shotwell/shotwell.post-upgrade b/testing/shotwell/shotwell.post-upgrade
new file mode 100644
index 00000000000..e6135da0452
--- /dev/null
+++ b/testing/shotwell/shotwell.post-upgrade
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in shotwell.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/testing/shotwell/shotwell.pre-deinstall b/testing/shotwell/shotwell.pre-deinstall
new file mode 100644
index 00000000000..9d3a0003005
--- /dev/null
+++ b/testing/shotwell/shotwell.pre-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in shotwell.schemas; do
+ echo "Uninstalling GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
+done