aboutsummaryrefslogtreecommitdiffstats
path: root/testing/soju/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/soju/makefile.patch')
-rw-r--r--testing/soju/makefile.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/testing/soju/makefile.patch b/testing/soju/makefile.patch
new file mode 100644
index 00000000000..f6b2bc819f0
--- /dev/null
+++ b/testing/soju/makefile.patch
@@ -0,0 +1,15 @@
+Don't create /var/lib/soju, it's done by soju.pre-install script
+with proper permissions.
+
+diff --git a/Makefile b/Makefile
+index af65f77..4cb971b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -33,7 +33,6 @@ install:
+ mkdir -p $(DESTDIR)$(PREFIX)/$(BINDIR)
+ mkdir -p $(DESTDIR)$(PREFIX)/$(MANDIR)/man1
+ mkdir -p $(DESTDIR)$(SYSCONFDIR)/soju
+- mkdir -p $(DESTDIR)$(sharedstatedir)/soju
+ cp -f $(commands) $(DESTDIR)$(PREFIX)/$(BINDIR)
+ cp -f $(man_pages) $(DESTDIR)$(PREFIX)/$(MANDIR)/man1
+ [ -f $(DESTDIR)$(config_path) ] || cp -f config.in $(DESTDIR)$(config_path)