aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sops/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/sops/APKBUILD')
-rw-r--r--testing/sops/APKBUILD39
1 files changed, 0 insertions, 39 deletions
diff --git a/testing/sops/APKBUILD b/testing/sops/APKBUILD
deleted file mode 100644
index 463b800830f..00000000000
--- a/testing/sops/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Contributor: Michał Polański <michal@polanski.me>
-# Maintainer: Michał Polański <michal@polanski.me>
-pkgname=sops
-pkgver=3.7.1
-pkgrel=0
-pkgdesc="Simple and flexible tool for managing secrets"
-url="https://github.com/mozilla/sops"
-license="MPL-2.0"
-arch="all"
-makedepends="go"
-source="https://github.com/mozilla/sops/archive/v$pkgver/sops-$pkgver.tar.gz
- skip-hcvault-tests.patch
- skip-pgp-tests.patch
- "
-builddir="$srcdir/sops-$pkgver"
-options="net" # for downloading Go modules
-
-export GOPATH="$srcdir"
-export GOFLAGS="-trimpath -modcacherw"
-export CGO_ENABLED=0
-
-build() {
- go build -v ./cmd/sops
-}
-
-check() {
- # remove -trimpath, tests fail otherwise
- GOFLAGS="${GOFLAGS/-trimpath}" go test ./...
-}
-
-package() {
- install -Dm755 sops "$pkgdir"/usr/bin/sops
-}
-
-sha512sums="
-e34b2bcdc45ebf97b77e497f825f29ea59c2794782929c9985f8e1368173c25a654fd67a81099e34d9fe5aa7750fea046565456e04750a329e317eafc4a395d1 sops-3.7.1.tar.gz
-e1e718955e40e392a6faa12706107375a524e40636e684f096a51e115eca356b6c22f1922e9b758dae1b4978f36c89a6e6030ac680f79a65c4ac68218b4cdc84 skip-hcvault-tests.patch
-9f1861a3e6c9fa5435a12d4052ef7c841fd58a15b75c3b4ab74e181185925970f69822c831252df1e2e44a673f88f220371d27392efd99c24e21e6cb5768778e skip-pgp-tests.patch
-"