aboutsummaryrefslogtreecommitdiffstats
path: root/testing/speedtest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/speedtest/APKBUILD')
-rw-r--r--testing/speedtest/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/testing/speedtest/APKBUILD b/testing/speedtest/APKBUILD
index ce8fe67738a..48f36b12b15 100644
--- a/testing/speedtest/APKBUILD
+++ b/testing/speedtest/APKBUILD
@@ -1,23 +1,22 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-_php=php7
+_php=php82
pkgname=speedtest
-pkgver=4.6.2
+pkgver=5.2.5
pkgrel=1
pkgdesc="Self-hosted HTML5 Speedtest"
-url="http://speedtest.fdossena.com"
+url="https://librespeed.org"
arch="noarch"
license="LGPL-3.0-only"
depends="$_php"
subpackages="$pkgname-doc $pkgname-examples"
-source="$pkgname-$pkgver.tar.gz::https://github.com/adolfintel/speedtest/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/librespeed/speedtest/archive/$pkgver.tar.gz"
options="!check" # no test suite
builddir="$srcdir"/$pkgname-$pkgver
_destdir="/usr/share/webapps/$pkgname"
_docdir="/usr/share/doc/$pkgname"
-
build() {
return 0
}
@@ -25,9 +24,8 @@ build() {
package() {
mkdir -p "$pkgdir"/$_destdir "$pkgdir"/$_docdir
mv *.md "$pkgdir"/$_docdir
- mv garbage.php getIP.php empty.php speedtest_worker.min.js speedtest_worker.js \
- "$pkgdir"/$_destdir
- mv example-gauges.html "$pkgdir"/$_destdir/index.html
+ mv backend results *.js "$pkgdir"/$_destdir
+ cp example-singleServer-pretty.html "$pkgdir"/$_destdir/index.html
}
examples() {
@@ -35,4 +33,6 @@ examples() {
mv "$builddir"/example* "$subpkgdir"/$_destdir
}
-sha512sums="24fef6d9e9b9428e145ac564a66effdfbd84630a9183cb5e1c568ec8bd18d3577920c7ba631103a2c3f27f35cd4e2637b0c2598d61b1afe40642f58a447b5bd4 speedtest-4.6.2.tar.gz"
+sha512sums="
+cf9ff33bea2a94c1d5b614d2f94eb9dad71fb1bd247f9a762ba9b8909adb1bf5a1286cd1ed98bbae43c3fc0f53474de2ef0cac670c358793df70c3ac17939f2d speedtest-5.2.5.tar.gz
+"